Messages

"Current notices about Posteo: News, developments, background information and media appearances."

Messages

Navigation

Enigmail users: do not update to Thunderbird 78

Created at 01.July 2020, 14:45 | Category: Blog

Dear Posteo customers and interested parties,

Today we address all users of the encryption add-on Enigmail in Thunderbird. If you regularly encrypt your emails with OpenPGP and depend on this feature, please avoid updating to the forthcoming Thunderbird release (version 78.0). Enigmail will no longer be supported in Thunderbird 78. The program’s new and own implementation of OpenPGP encryption is still in an experimental phase and is deactivated by default.

Should you use automatic updates, no further action is required. An installation of the Thunderbird 78 update will not occur automatically.

Background information:
This summer, Mozilla is planning on releasing a new version of Thunderbird (78.0) that will change how add-ons are supported. Among other reasons, this became necessary due to security issues.
This was also made clear from a security audit commissioned by Posteo at the end of 2017. Various security issues in Thunderbird were identified, particularly with its add-on interface.

Third-party add-ons like Enigmail, that need to access internal components of Thunderbird, will no longer be supported.

Because of this, Mozilla is implementing their own OpenPGP feature in Thunderbird 78. This built-in encryption is planned to replace the Enigmail add-on..
Currently OpenPGP support in Thunderbird 78 is categorised as experimental and is disabled by default: Enigmail is no longer supported in Thunderbird 78.

Waiting for Thunderbird 78.2

From Thunderbird 78.2 onwards, OpenPGP is planned to be made available by default in Thunderbird. We will inform you as soon as this version is made available and an update for OpenPGP users is possible.

Best regards
The Posteo Team